Author Topic: 390 Water Pump issue  (Read 1117 times)

0 Members and 1 Guest are viewing this topic.

Offline TimL

  • 62 Series Member
  • *
  • Posts: 22
    • My '59 Cadillac Journey
  • Location: Melbourne
  • My Name: Tim
390 Water Pump issue
« on: October 01, 2015, 08:52:43 AM »
I have just completed building my 390 engine for the 59, and bought a new water pump as part of the build.  I have just installed the water pump pulley and found that it is 3mm too far forward.

Further investigations reveal that it looks like the water inlet and outlet faces all have approx 3mm more meat on them, which pushes the pulley forward by 3mm.

Has anyone come across this before?

Super disappointing, and of course frustrating.  The only fix I can think of is removing the pump and having a machine shop machine 3mm off of the surfaces.  I cant see that spacing every other pulley forward by 3mm is an option.

Offline TimL

  • 62 Series Member
  • *
  • Posts: 22
    • My '59 Cadillac Journey
  • Location: Melbourne
  • My Name: Tim
Re: 390 Water Pump issue
« Reply #1 on: October 01, 2015, 01:06:11 PM »
Some more dimensional checking and it looks like the pulley flange has not been pressed on far enough (it is actually 4mm).  I am going to have to see if I know someone with a hydraulic press.

Interestingly, a number of the water pump bolt flanges are not the correct height, which affects how the A/C compressor and Generator mounting bracket sits.  I will have to pack up each point with washers to get them where they need to be.

It is the attention to detail that seems to let so many after market manufacturers down.

Offline Bruce Reynolds

  • Club Member
  • Brougham Member
  • **
  • Posts: 1263
Re: 390 Water Pump issue
« Reply #2 on: October 01, 2015, 01:55:18 PM »
What brand is it?

An aftermarket brand?

As a word of caution, when pressing the flange deeper onto the shaft, make sure that the back plate of the pump has been removed, and the end of the shaft is resting on the bottom mandrel.

If not, the casting will break.

Bruce. :devil:
Bruce Reynolds, Lindisfarne, TASMANIA
'72 Eldorado Convertible (LHD)
'70 Ranchero Squire (RHD)
'74 Chris Craft Gull Wing (SH)
(Past President Modified Chapter)

Offline TimL

  • 62 Series Member
  • *
  • Posts: 22
    • My '59 Cadillac Journey
  • Location: Melbourne
  • My Name: Tim
Re: 390 Water Pump issue
« Reply #3 on: October 06, 2015, 09:32:42 PM »
Hi Bruce,

I bought it from Falcon Global on eBay, who seem to specialize in classic car bits.  Everything else I bought from them was a quality item, so I just expected this to be the same.  The original pump design has been modified to reduce the likely hood of leaking (apparently).

I removed the rear plate and supported the pump shaft and impeller before I nudged it on a little further.

The outcome was the pulley now lines up with the crank pulleys  ;-)

I am getting closer to dropping the engine back in....can't wait to start it.

...Tim

See my blog here...  https://1959cadillacfinmonster.wordpress.com/